Back to overview
Downtime
Some services are down
May 21 at 12:34am UTC
Affected services
USER SERVICES
Resolved
May 22 at 05:45pm UTC
we have identified the root cause of the issue. and all the Services were restored .
Thank you for your patience!
Affected services
Created
May 21 at 12:34am UTC
USER SERVICES went down. and we have figured out the issue. Soon the services will be restored to normal
Affected services